Open Grieves

Open Grieves

Assimilate quickly!

You must comply!

Troubleshooting Azure deployment template for OpenShift

Out of troublePosted by Magnus Glantz 2017-02-07 13:14:13
Hi all,

If you are trying out to deploy OpenShift on Azure using instructions here: http://blog.hacka.net/#123

..And you got errors doing that. Here's how to debug the deployment process. It's easy to type the wrong this. Try to keep to just copy-and-pasting if you are using the template in the Azure Portal. Trust me :)

1. Click on the resource group you've created.

2. Click on your deployment. It should say "1 Deploying" (or 2)

3. Click on "Microsoft Template"



4. Scroll down to "Operations details"



5. Find the resource which does not state "OK" or "Created". Should be marked in red and state something like "Conflict" or "Error".

6. Find out what went wrong. In this example, it's a custom script which failed to run.



7. Logon to the server affected and follow the below debug flow:

[root@ocpmaster ~]# cd /var/lib/waagent/custom-script/download/
[root@ocpmaster download]# ls
0 1
[root@ocpmaster download]# ls */
0/:
masterPrep.sh stderr stdout

1/:
deployOpenShift.sh stderr stdout
[root@ocpmaster download]# cd 1
[root@ocpmaster 1]# tail stderr
Adding password for user mglantz
error: A server URL must be specified
[root@ocpmaster 1]#

8. Issue found.



  • Comments(0)

Fill in only if you are not real





The following XHTML tags are allowed: <b>, <br/>, <em>, <i>, <strong>, <u>. CSS styles and Javascript are not permitted.